Autor Thema: Umlaut-Probleme bei der Vorschau  (Gelesen 3867 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Sandmännchen

  • Praktikant- Lennéstraße
  • ****
  • Beiträge: 4439
  • Dankeschön: 6886 mal
  • Karma: 317
  • Garstiger Philantrop (m/w/d)
  • Auszeichnungen Wertvolle Beiträge! Schon 100 "Danke" erhalten Auszeichnung für 2250 Beiträge Dieser Benutzer hat dem Sonnenstaatland besondere Dienste erwiesen! Sehr Wertvolle Beiträge! Bereits 1000 "Danke" erhalten! Auszeichnung für 1500 Beiträge
    • Auszeichnungen
Umlaut-Probleme bei der Vorschau
« am: 10. Mai 2014, 21:34:10 »
Ich hab' jetzt keinen besseren Bereich gefunden, und in einer PN an den Admin kann man keine Anhänge hinzufügen ...

Wenn ich auf einen Beitrag antworte (ich drücke "Antwort"), ist erst mal alles in Ordnung. Wenn ich dann in der Antwort Umlaute eingebe und dann den Vorschau-Button drücke, stimmt etwas mit den Umlauten nicht (sieht danach aus, als ob der Browser die Formulardaten in UTF-8 liefert, der Server sie dann als iso-latin-irgendwas interpretiert). Anbei ein Screenshot.

Ich nutze Firefox 29.0 unter Linux. "Character Encoding for Legacy Content" steht auf "Default for current locale". Mein locale setting ist de_DE.utf-8



soɥdʎsıs sǝp soɥʇʎɯ ɹǝp 'snɯɐɔ ʇɹǝqlɐ –
˙uǝllǝʇsɹoʌ uǝɥɔsuǝɯ uǝɥɔılʞɔülƃ uǝuıǝ slɐ soɥdʎsıs sun uǝssüɯ ɹıʍ ˙uǝllüɟnzsnɐ zɹǝɥuǝɥɔsuǝɯ uıǝ ƃɐɯɹǝʌ lǝɟdıƃ uǝƃǝƃ ɟdɯɐʞ ɹǝp
 

Offline Sonnenstaatland®

  • Administrator
  • Kommissar Mimimi
  • *****
  • Beiträge: 765
  • Dankeschön: 887 mal
  • Karma: 88
  • Auszeichnungen Auszeichnung für 750 Beiträge Dieser Benutzer hat dem Sonnenstaatland besondere Dienste erwiesen! Auszeichnung für 500 Beiträge Geheimnisträger, Sir! Beliebt! 50 positives Karma erhalten
    • Anti-Kommissarische-Reichsregierung-Sonnenstaatland
    • Auszeichnungen
Re: Umlaut-Probleme bei der Vorschau
« Antwort #1 am: 11. Mai 2014, 12:59:58 »
Hallo Sandmännchen,

wir können weder mit Chrome, FF, IE oder Safari diesen Fehler reproduzieren. Tritt der Fehler weiterhin bei dir auf?
 

Offline Sandmännchen

  • Praktikant- Lennéstraße
  • ****
  • Beiträge: 4439
  • Dankeschön: 6886 mal
  • Karma: 317
  • Garstiger Philantrop (m/w/d)
  • Auszeichnungen Wertvolle Beiträge! Schon 100 "Danke" erhalten Auszeichnung für 2250 Beiträge Dieser Benutzer hat dem Sonnenstaatland besondere Dienste erwiesen! Sehr Wertvolle Beiträge! Bereits 1000 "Danke" erhalten! Auszeichnung für 1500 Beiträge
    • Auszeichnungen
Re: Umlaut-Probleme bei der Vorschau
« Antwort #2 am: 11. Mai 2014, 13:11:25 »
Hallo Sandmännchen,

wir können weder mit Chrome, FF, IE oder Safari diesen Fehler reproduzieren. Tritt der Fehler weiterhin bei dir auf?

Ja (s.o.) ;)

soɥdʎsıs sǝp soɥʇʎɯ ɹǝp 'snɯɐɔ ʇɹǝqlɐ –
˙uǝllǝʇsɹoʌ uǝɥɔsuǝɯ uǝɥɔılʞɔülƃ uǝuıǝ slɐ soɥdʎsıs sun uǝssüɯ ɹıʍ ˙uǝllüɟnzsnɐ zɹǝɥuǝɥɔsuǝɯ uıǝ ƃɐɯɹǝʌ lǝɟdıƃ uǝƃǝƃ ɟdɯɐʞ ɹǝp
 

Offline Sandmännchen

  • Praktikant- Lennéstraße
  • ****
  • Beiträge: 4439
  • Dankeschön: 6886 mal
  • Karma: 317
  • Garstiger Philantrop (m/w/d)
  • Auszeichnungen Wertvolle Beiträge! Schon 100 "Danke" erhalten Auszeichnung für 2250 Beiträge Dieser Benutzer hat dem Sonnenstaatland besondere Dienste erwiesen! Sehr Wertvolle Beiträge! Bereits 1000 "Danke" erhalten! Auszeichnung für 1500 Beiträge
    • Auszeichnungen
Re: Umlaut-Probleme bei der Vorschau
« Antwort #3 am: 11. Mai 2014, 13:13:46 »
Weitere Beobachtungen: Wenn ich auf "Antworten" klicke, steht "Character Encoding" im Menü "View" auf "Unicode". Sobald ich auf "Vorschau" klicke, wechselt es auf "Western".
soɥdʎsıs sǝp soɥʇʎɯ ɹǝp 'snɯɐɔ ʇɹǝqlɐ –
˙uǝllǝʇsɹoʌ uǝɥɔsuǝɯ uǝɥɔılʞɔülƃ uǝuıǝ slɐ soɥdʎsıs sun uǝssüɯ ɹıʍ ˙uǝllüɟnzsnɐ zɹǝɥuǝɥɔsuǝɯ uıǝ ƃɐɯɹǝʌ lǝɟdıƃ uǝƃǝƃ ɟdɯɐʞ ɹǝp
 

Offline kairo

Re: Umlaut-Probleme bei der Vorschau
« Antwort #4 am: 11. Mai 2014, 13:44:38 »
Hallo Sandmännchen,

wir können weder mit Chrome, FF, IE oder Safari diesen Fehler reproduzieren. Tritt der Fehler weiterhin bei dir auf?

Bei mir auch - siehe meinen neuesten Beitrag. Ich habe FF, allerneueste Version. Bisher war es nicht so.
 

Offline Sandmännchen

  • Praktikant- Lennéstraße
  • ****
  • Beiträge: 4439
  • Dankeschön: 6886 mal
  • Karma: 317
  • Garstiger Philantrop (m/w/d)
  • Auszeichnungen Wertvolle Beiträge! Schon 100 "Danke" erhalten Auszeichnung für 2250 Beiträge Dieser Benutzer hat dem Sonnenstaatland besondere Dienste erwiesen! Sehr Wertvolle Beiträge! Bereits 1000 "Danke" erhalten! Auszeichnung für 1500 Beiträge
    • Auszeichnungen
Re: Umlaut-Probleme bei der Vorschau
« Antwort #5 am: 11. Mai 2014, 13:59:07 »
Ich habe mir das mal näher angesehen. Euer Webserver sagt in den HTTP-Headern:

Content-Type: text/html
Könnt ihr das auf das folgende umstellen?

Content-Type: text/html; charset=utf-8
Die Chancen stehen gut, daß es weiterhilft.
« Letzte Änderung: 11. Mai 2014, 14:04:23 von Sandmännchen »
soɥdʎsıs sǝp soɥʇʎɯ ɹǝp 'snɯɐɔ ʇɹǝqlɐ –
˙uǝllǝʇsɹoʌ uǝɥɔsuǝɯ uǝɥɔılʞɔülƃ uǝuıǝ slɐ soɥdʎsıs sun uǝssüɯ ɹıʍ ˙uǝllüɟnzsnɐ zɹǝɥuǝɥɔsuǝɯ uıǝ ƃɐɯɹǝʌ lǝɟdıƃ uǝƃǝƃ ɟdɯɐʞ ɹǝp
 

Offline kairo

Re: Umlaut-Probleme bei der Vorschau
« Antwort #6 am: 11. Mai 2014, 15:22:34 »
Für die Doofen: wie macht man das bei Firefox?
 

Offline kairo

Re: Umlaut-Probleme bei der Vorschau
« Antwort #7 am: 11. Mai 2014, 15:23:05 »
Interessant, diesmal habe ich keine Vorschau benutzt, und das mit dem ü funktioniert.
 

Offline kairo

Re: Umlaut-Probleme bei der Vorschau
« Antwort #8 am: 11. Mai 2014, 15:23:29 »
Und jetzt mit: äöüß ...
 

Offline kairo

Re: Umlaut-Probleme bei der Vorschau
« Antwort #9 am: 11. Mai 2014, 15:23:56 »
Der Wurm steckt in der Vorschau, also wohl doch beim Server des Forums.
 

Offline Decimus

Re: Umlaut-Probleme bei der Vorschau
« Antwort #10 am: 11. Mai 2014, 15:25:03 »
Liegt das vielleicht am Wechsel der Subdomain?
 

Offline Sandmännchen

  • Praktikant- Lennéstraße
  • ****
  • Beiträge: 4439
  • Dankeschön: 6886 mal
  • Karma: 317
  • Garstiger Philantrop (m/w/d)
  • Auszeichnungen Wertvolle Beiträge! Schon 100 "Danke" erhalten Auszeichnung für 2250 Beiträge Dieser Benutzer hat dem Sonnenstaatland besondere Dienste erwiesen! Sehr Wertvolle Beiträge! Bereits 1000 "Danke" erhalten! Auszeichnung für 1500 Beiträge
    • Auszeichnungen
Re: Umlaut-Probleme bei der Vorschau
« Antwort #11 am: 11. Mai 2014, 15:36:18 »
Unwahrscheinlich. Das Spekulieren bringt keinen weiter.

Ich hab übrigens 'nen Workaround: Nach "Vorschau" in View/Character Encoding einfach wieder auf Unicode setzen.
soɥdʎsıs sǝp soɥʇʎɯ ɹǝp 'snɯɐɔ ʇɹǝqlɐ –
˙uǝllǝʇsɹoʌ uǝɥɔsuǝɯ uǝɥɔılʞɔülƃ uǝuıǝ slɐ soɥdʎsıs sun uǝssüɯ ɹıʍ ˙uǝllüɟnzsnɐ zɹǝɥuǝɥɔsuǝɯ uıǝ ƃɐɯɹǝʌ lǝɟdıƃ uǝƃǝƃ ɟdɯɐʞ ɹǝp
 

Offline A.R.Schkrampe

Re: Umlaut-Probleme bei der Vorschau
« Antwort #12 am: 11. Mai 2014, 16:37:42 »
Für die Doofen: wie macht man das bei Firefox?

Muß man das? Ich nutze ebenfalls Firefox und habe Sandmännchens Probleme weder hier, noch woanders gehabt.

@Sandmännchen: hast Du evtl. Deine Tastatur falsch eingestellt, auf eine andere Tastenbelegung?

 

Offline Sandmännchen

  • Praktikant- Lennéstraße
  • ****
  • Beiträge: 4439
  • Dankeschön: 6886 mal
  • Karma: 317
  • Garstiger Philantrop (m/w/d)
  • Auszeichnungen Wertvolle Beiträge! Schon 100 "Danke" erhalten Auszeichnung für 2250 Beiträge Dieser Benutzer hat dem Sonnenstaatland besondere Dienste erwiesen! Sehr Wertvolle Beiträge! Bereits 1000 "Danke" erhalten! Auszeichnung für 1500 Beiträge
    • Auszeichnungen
Es geht! Ich bin drin!!!
« Antwort #13 am: 11. Mai 2014, 18:34:46 »
Ooch bitte, da fehlt auch noch jeder Zusammenhang. Meiner Tastatur ist doch die Kodierung vom Server wurst.

Aber der Staatsmechaniker hat meine Bitten erhört, im http-Header steht nun die magische Formel "Content-Type: text/html; charset=utf-8", und siehe da, alles ward gut, und auch die Vorschau beläßt die Umlaute. Danke! Endlich mal mit Profis arbeiten!  ^-^ - woanders klappt sowas nie, warum auch immer.

Euren Graphiker find ich übrigens auch spitze!
soɥdʎsıs sǝp soɥʇʎɯ ɹǝp 'snɯɐɔ ʇɹǝqlɐ –
˙uǝllǝʇsɹoʌ uǝɥɔsuǝɯ uǝɥɔılʞɔülƃ uǝuıǝ slɐ soɥdʎsıs sun uǝssüɯ ɹıʍ ˙uǝllüɟnzsnɐ zɹǝɥuǝɥɔsuǝɯ uıǝ ƃɐɯɹǝʌ lǝɟdıƃ uǝƃǝƃ ɟdɯɐʞ ɹǝp
 

Offline A.R.Schkrampe

Re: Es geht! Ich bin drin!!!
« Antwort #14 am: 11. Mai 2014, 19:33:44 »
Ooch bitte, da fehlt auch noch jeder Zusammenhang. Meiner Tastatur ist doch die Kodierung vom Server wurst.

Woher soll ich diese Details wissen? Ich bin ein ahnungsloser (fast hätte ich "merkbefreiter" geschrieben...) User, kein PC-Experte.


P.S. A propos "Sandmännchen". "Meines" ist übrigens dieses hier:


http://www.youtube.com/watch?v=5k7bblmlAFc



Wobei ich schon zu Kindergartenzeiten in der Minderheit war. Die DDR-Version war auch im Westen (wich wuchs in einer Region auf, wo beide DDR-TV-Programme empfangbar waren) beliebter.
« Letzte Änderung: 11. Mai 2014, 19:37:18 von A.R.Schkrampe »